Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Published by Scroll Versions from space TEADOC and version 6.2
Sv translation
languageen

Teamstudio Adviser consists of two components, an IBM Domino application hosted on a Domino server, and an executable program that runs on a workstation with an IBM Notes client installed.  

The Adviser server application provides Adviser's browser-based user interface, generates reports on databases and users for the Adviser modules, and stores all data collected by Adviser.  Adviser server is deployed by creating an NSF based the template TSAdviser.ntf on the desired server, and configuring it via web browser.

Adviser workstation is responsible for collecting the data that forms the basis for the reports generated by the Adviser server.  Adviser workstation is deployed by running an installer (contained in the server NSF) on a workstation installation of IBM Notes.  The installed program is configured by the installer to connect to the Adviser server, and remains running to process Adviser scans as needed.  Scans are resource intensive processes; running scans from a client workstation limits the impact of Adviser on server performance, and allows easier configuration and access to servers in multiple domains.

System Requirements 

The web interface for Teamstudio Adviser can be hosted on any Domino server version 8.5.3 or above, with the HTTP task enabled.

  • For Domino 8.5.3, the server must have a minimum of Fix Pack 3 installed, and must have Upgrade Pack 1 installed (or equivalent version of the Xpages Extension Library).
  • The required components are included in Domino 9.0 and greater; no additional components are required.

The Teamstudio Adviser workstation is supported on Notes version 8.5.3 and higher (32-bit) running on supported versions of Microsoft Windows.

Upgrading an Existing Installation

If you are upgrading an existing installation of Adviser 6.0 or above, you can skip directly to the Upgrading section. Otherwise continue to follow the instructions below.

Prerequisites for Usage Data Collection

The Usage module of Teamstudio Adviser aggregates and reports on data collected by the IBM Domino server’s Activity Logging task.

In order to use Usage Auditor, Activity Logging must be enabled on all servers you wish to include.

Activity Logging can be enabled on the Server Configuration document in the Domino Directory database. Teamstudio Adviser tracks the following activity streams:

  • Domino.Notes.Database
  • Domino.Notes.Session
  • Domino.AGENT
  • Domino.HTTP 

By default, Activity is logged to the Log.nsf database on the server, and the retention period for Log.nsf applies to activity as well. By default, Teamstudio Adviser will collect usage data every night and will import any new data. If collection fails, no data will be lost as long as the problem is resolved within the retention period.

Installing and Configuring Teamstudio Adviser Server

Installation

To install the server component, sign the TSAdviser.ntf template with an ID appropriate to execute code and access servers to be scanned, and create an NSF from the template on the desired server.

To configure Teamstudio Adviser, connect to the application via web-browser, using an address in the form http(s)://<server>/<path>/index.html, where <server> is the host name or IP address of the Domino server, and <path> is the file path of the NSF.  For convenience, the NSF displays this URL when opened in a Notes Client.

If installation is successful, you should see the application home screen.

ACL

By default, Teamstudio Adviser server requires that the ACL entry "anonymous" be defined as "No Access" and given the privilege "Read Public Documents" – this setting allows the Adviser workstation to trigger server-side job processing when client-side jobs have completed.  Anonymous access cannot be used to create jobs or access data.  Anonymous should not be set to a higher level of access, as authentication is required by the Adviser services that support the web browser application.  Allowing anonymous higher levels of access will prevent the server from requiring authentication. 

If the environment does not allow Anonymous access (for example, it is prohibited at the server level via the Directory's Server document), it is possible to configure Adviser to store and use an HTTP Username/Password combination for this access.  For more information, contact Teamstudio support at techsupport@teamstudio.com.

In general, other ACL settings in Adviser are applied to the browser application in the same manor they are applied in traditional Notes applications.

The "-Default-" access setting can be used to assign any level of access desired in place of anonymous access.

Configuration

The final step in configuring the Teamstudio Adviser server is to select the servers to scan. You can do this from the Settings page in the web application, accessed via the gear icon on the right of the Adviser navigation bar. See Servers for more details.

Installing the Adviser data collection application on workstations

The Adviser Workstation application is a executable application that run scans from a client workstation.  Scanning for and reporting on activity is a resource intensive activity that may access multiple servers and which works with file system files as part of the process.

The data collected during the Workstation scans is written to the server application, and available via the web browser interface.

Adviser Workstation is intended to run continuously, as it monitors the Adviser Server component, waiting for scans to be scheduled.

The application must be run by ID that has a least Reader access to the Log.nsf files on the servers to be scanned, as well as any applications for which Complexity data is desired.  If the servers exist in multiple domains, the ID and local workstation must be properly cross-certified to all servers.

The ID must also have Editor level ACL access (with delete rights) to the Adviser Server application.

Installing the Adviser Workstation application

  1. On the workstation where the Adviser workstation will run, log in to the IBM Notes client with the ID that will be used to collect data.
  2. Ensure that the Notes client setting "Don't prompt for password from other Notes-based programs" is checked (File > Security > User Security).  This step is required to allow the executable to run.
  3. Open the Adviser server application in the Notes client, and click on the link to enable workstation processing in the section titled Adviser Workstation:

  4. The Adviser Workstation installer program will launch.  Follow the prompts to install the program.  During setup, a settings page will be shown which contains configuration information for the Workstation and it's connection to the server; verify the information is correct:

 

When the installation is complete, the installer will offer to launch the Workstation application.

For information on upgrading  an existing Adviser install, see the Upgrading section below.

For more information and assistance upgrading a prior version of Usage Auditor, contact Teamstudio Support at http://support.teamstudio.com or by email at techsupport@teamstudio.com.


Launching the Adviser Workstation

Once installed, the Adviser workstation can be launched by clicking the same link used to install it,  found in the Configuration page of the Adviser server NSF when opened in the Notes client, in the section titled Adviser Workstation:

The workstation can also be launched by running the executable Workstation.exe, which is installed by default at <Program Files (x86)>\Teamstudio\Adviser Workstation\Workstation.exe

Once launched, the Workstation application window should open, and begin monitoring for pending scans:

Workstation - Server Connectivity

Adviser workstation requires connectivity to the Adviser server via HTTP.

Most workstation processing, including scanning servers and databases, and writing data to the Adviser server, is handled through the Notes client and NRPC.

In order to trigger server processing once client side jobs have completed, Adviser invokes a REST service endpoint via HTTP to ensure that the server application is running to process the updated data.

The default workstation configuration attempts to connect to the server based on the fully-qualified host name specified first in the server document in the server's address book.  The connection is attempted without SSL on port 80.

For servers requiring SSL connections, or connectivity on an alternate port, the configuration can be modified by editing the HTTP Host Name field in the Workstation Configuration document in the workstation database.  By default this field contains only the host name; a protocol and optional port name can be specified (for example, https://teamstudio.com:499 specifies SSL on port 499).  The Notes client acting as the Adviser workstation must be exited completely and restarted for this setting to take effect.  For help configuring these settings, contact Teamstudio support.

Due to limitations with the Java 6 JVM currently embedded in Notes, SSL that uses large key sizes may not work correctly. 

Anchor
Upgrading
Upgrading
Upgrading Adviser

To upgrade from a previous version of Adviser 6.0 or greater, follow the steps below.  

Upgrade Adviser Server

  1. Sign the new template with the appropriate ID to execute code on the target server.
  2. Refresh the design of the server Adviser database from the new template.
  3. Restart the HTTP task on the server using the command "restart task http"  (this is equivalent to "quit http" followed by "load http" - note that "tell http restart" will not fully release the JVM and update the new code).

Upgrade Adviser Workstation

The Adviser Workstation install prior to 6.2 ran the workstation component as a locally scheduled agent in the Notes client, from the Notes application TSAdviserWS.nsf located in the root of Note's "data" directory.   To upgrade, follow these steps:

  1. Exit the Notes client acting as the workstation completely (this can be confirmed using task manager).
  2. Delete TSAdviserWs.nsf from the client's data directory.
  3. Restart the Notes client, open the Adviser Server application.
  4. Follow the instructions above for installing Adviser Workstation.
  5. In the browser UI, schedule a new scan.  This will update the data as needed for the new version, and enable any new features. It is safe to schedule a scan while waiting for the workstation to restart; the scan will begin once the workstation is active.

If you have been running a previous Beta version of Adviser Workstation which runs as a command-line application, exit the application and install the new Workstation application by following the instructions above (depending on the version, you may be prompted to uninstall Adviser Workstation via Windows' Programs and Features control panel prior to installing the new version).

Browsers and Saved Passwords

Adviser does not currently support using "Saved Passwords" in browsers.  Previously saved passwords can be removed via the browser's settings page.

Scheduling Daily Scans

Since Adviser extracts activity data from the server's log.nsf, which typically keeps 7-10 days of data, it's important to run Usage Scans on a regular basis to insure the data is up-to-date and without gaps.

To enable nightly scanning, open the Adviser server application in Domino Designer, navigate to Agents, and enable the agent Schedule Nightly Scan.  When prompted for the server to run on, choose the server on which the server application resides.  Check that the agent is signed with an ID capable of running scheduled agents on that  server.

By default, this agent will run once daily, at 1:00 AM.  The run time can be modified to another time if desired.

The Schedule Nightly Scan agent initiates the same process as triggering a manual scan using the Scan Now button in the application.  The scan will update Catalog information, import Usage since the last scan, and recalculate any affected metrics.  Workstation processing must be enabled for the scan request to be processed. 

Importing Usage data from Usage Auditor

Usage data from Teamstudio Usage Auditor can be imported if the setting Save Supporting Data was enabled during the period of usage collection.  Click here for information on importing from Usage Auditor.

 

 

 

Sv translation
languageja

Teamstudio Adviser はふたつの Lotus Notes アプリケーションから構成されており、IBM Notes 環境に関するデータをスキャンおよび集約しレポートを生成します。これには、サーバーから生の利用状況アクティビティログデータを収集する実行モジュールも含まれています。

Adviser のユーザーインターフェースは、Web アプリケーションとして提供され、HTTP が有効になっている単一の Domino サーバー上で運用します。主なるアプリケーション、TSAdviser.nsf は、Web アプリケーションとして動作し、サーバー上に NSF を作成して配置し Web ブラウザを経由して設定します。

カタログ、利用状況、複雑さのすべてのデータ収集は、異なるワークステーションで実行されるようにデザインされています。ふたつめのアプリケーション、TSAdviserWS.nsf は IBM Notes のワークステーションに配置します。このアプリケーションはスキャンをスケジュールし実行する役割を持っています。指定したワークステーションからサーバーアプリケーションのアクションを実行することで自動的に配置されます。スキャンはリソースを著しく消費するプロセスですが、異なるワークステーションから実行して、サーバーパフォーマンスの Adviser のインパクトを抑制し、複数ドメインのアクセスを容易にする利点があります。

システム要件 

Teamstudio Adviser の Web ユーザーインターフェースは、Domino サーバーのバージョン 8.5.3 以降で運用します。

  • Domino 8.5.3 では、少なくとも Fix Pack 3 と Upgrade Pack 1 (または XPages Extension Library) がインストールされていなければなりません。
  • 上記に必要なコンポーネントは Domino 9.0 以降に含まれているので、追加のコンポーネントは必要ありません。

Teamstudio Adviser のワークステーションは Windows 上で Notes クライアントが構成されている IBM がサポートするすべての 32 ビット構成をサポートしています。

既存のインストールをアップグレードする方法

Adviser 6.0 以降の既存のインストールからアップグレードする場合には Upgrading セクションを参照してください。そうでない場合は、下の方法に従ってください。

利用状況データ収集の前提要件

Teamstudio Adviser は IBM Domino サーバーのアクティビティロギングタスクで収集されたデータを元に、集積とレポートを行います。

Usage Auditor の使用には、対象となるサーバーすべてにアクティビティロギングを有効化する必要があります。
アクティビティロギングはドミノディレクトリーのサーバー設定文書で有効にできます。Usage Auditor は次のアクティビティ・ストリームを追跡します:

  • Domino.Notes.Database
  • Domino.Notes.Session
  • Domino.AGENT
  • Domino.HTTP


Domino 上のアクティビティロギングの設定におけるデフォルトは、アクティビティの情報がサーバー上の Log.nsf データベースに書き込まれ、最新の 2 週間分だけアクティビティ情報が保存されるようになっています。Usage Auditor はアクティビティの収集において不足がないように定期的に動作するようになっています。つまり、アクティビティを Usage Auditor を使って記録すれば、レポーティングを開始した直後から「すべてのアクティビティ」のサマリー情報を保持できるようになります。

上記のようにすでにアクティビティロギングの設定がオンになっていれば、Usage Auditor を直ちに起動し、設定を行うだけで Log.nsf 内のアクティビティをレポート可能になります。

Teamstudio Adviser Server のインストールと設定

インストール

メインとなるサーバーコンポーネントをインストールするには、TSAdviser.ntf に対してプログラムコードを実行し、スキャンするサーバー群にアクセスできる適切な ID で署名する必要があります。そして、配置するサーバーにこのテンプレートを基に NSF を作成します。

Teamstudio Adviser を設定するには、次にアドレスを使用して Web ブラウザを経由してアプリケーションに接続します。 http(s)://<server>/<path>/index.html <server> は Domino サーバーのホスト名か IP アドレス、<path> はこの NSF のファイルパスを指定します。確認のために、この NSF では Notes クライアントで開いた際にこの URL を表示します。

インストールが成功すると、アプリケーションのホーム画面が表示されます。

ACL

Teamstudio Adviser サーバーは「Anonymous」のACLエントリが必要で、「アクセスなし」で「パブリック文書[読者]」の権限が必要です。この設定は Adviser ワークステーションがクライアント側でのジョブが完了したとき、サーバー側でのジョブを起動するのに必要です。Anonymousのアクセスはジョブを作成したりデータにアクセスするために使用できません。Webブラウザアプリケーションをサポートする Adviser のサービスで必要な権限として、Anonymous をそれ以上の高い権限に設定しないでください。Anonymous に高い権限を与えることは、サーバーが権限を必要とするのを妨げてしまうことになります。

通常、Adviser に設定するその他の ACL 設定は、普通のノーツアプリケーションに適用するのと同じ方法でブラウザアプリケーションにも適用できます。

「-Default-」アクセスは匿名のアクセスとして、必要となるどのレベルのアクセスにもアサインできます。

設定
Teamstudio Adviser サーバーでの設定の最後のステップは、スキャン対象のサーバーを指定することです。Web アプリケーションの Settings (設定) ページで行えます。設定ページは Adviser ナビゲーションバーの右側にある歯車アイコンからアクセスできます。詳しくは Servers を参照してください。

ワークステーション上に Adviser データ収集アプリケーションをインストールする方法

Adviser のデータ収集アプリケーションは TSAdviserWS.ntf というテンプレートを基にした Notes のアプリケーションです。

このアプリケーションはクライアントワークステーションからスキャンを実行するようにデザインされています。アクティビティをスキャンしレポートすることは、複数のサーバーにアクセスし、コンピュータープロセスの一部として動作する非常にリソースを消費するアものになります。

こうしてスキャンした利用状況アクティビティデータは、順次サーバーアプリケーションへ書き込みされ、Web ブラウザインターフェースを経由して利用できます。

Adviser ワークステーションはローカルの定期エージェントが動作する環境が必要で、保留されたジョブに対するサーバーアプリケーションの監視や、データ収集を動作させるの必要となります。 

アプリケーションはスキャン対象となるそれぞれのサーバーの Log.nsf ファイルに少なくとも読者権限のアクセスをもつ ID でインストールまたは動作させなければなりません。複雑さデータ収集が必要であれば、それぞれのアプリケーションに対しても同様のアクセス権がなければなりません。サーバー群が複数ドメイン内に存在している場合には、すべてのサーバーに対して相互認証されている ID とワークステーションが必要となります。

またこの ID は Adviser サーバーアプリケーションに対して、編集者(削除権限付き)の ACL アクセスを設定しなければなりません。

Adviser ワークスーテーションノーツアプリケーションをインストールするには:

  1. Adviser ワークステーションが動作するワークステーション上で、データ収集に使用される ID で IBM Notes クライアントにログインします。
  2. Notes クライアント設定の「定期ローカルエージェントの有効化」にチェックしてください。(ファイル > 設定 > IBM Notes クライアントの基本設定)。
  3. Notes クライアントのセキュリティ設定で「他の IBM Notes ベースのプログラムでパスワードプロンプトを表示しない(セキュリティが低下)」にチェックしてください(ファイル > セキュリティ > ユーザーセキュリティ)。これは実行モジュールを動作させるのに必要となります。
  4. Notes クライアントで Adviser サーバーアプリケーションを開き、Enable  Workstation Processing のリンクをクリックします:

実行モジュールのインストール

Adviser は logscan.exe というユーティリティプログラムを使用します。これを使用して、 Domino サーバー群からアクティビティの生データを収集します。

スキャンが実行されて、Notes プログラムディレクトリーにこのユーティリティ・プログラムがまだインストールされていない場合には、Adviser は自動でインストールします。自動インストールには現在のユーザーがインストールに必要な適切な OS 上の権限があることが必要です。

Notes プログラムディレクトリーにこの実行モジュールが自動で保存されない場合など管理者権限が必要な場合には、このデータベースの ヘルプ > このアプリケーションについて に添付されています。マニュアルで Notes 実行ディレクトリーに保存してください。

保存してから、Notes で Usage Auditor を起動するユーザーアカウントをこの実行モジュールが読み取り、実行できる Winodws OS 上の権限を与えてください。

Usage Auditor の以前のバージョンからアップグレードをする際に情報やサポートが必要な場合は、次のTeamstudio サポート http://support.teamstudio.com または次のメールアドレスまでお問い合わせください techsupport_japan@teamstudio.com.

ワークステーションの JVM メモリーの設定

Adviser ワークステーションは Java でプログラムされたスキャンジョブを実行します。 Complexity スキャンの実行中にサイズの大きな設計ノートや大きいサイズのデータキャッシュ(例えば、 Usage Auditor の以前のデータをインポートするなど)を処理するのに充分なメモリーが必要です。

Notes をインストールしたときのデフォルトの JVM ヒープの制限は 64 MB になっており、これでは大きなサイズの設計要素(例えば、大きな添付のあるフォーム)を処理するのには十分ではない場合があります。

この制限はワークステーションの Notes.ini パラメーター JavaMaxHeapSize=<バイト数> を指定することで変更できます。

当社では すくなくとも 128 MB、ほとんどの場合は 256 MB への変更を推奨します。

256 MB にヒープの制限値を変更するには、次の行を追加あるいは変更してください:  JavaMaxHeapSize=268435456

ワークステーションのジョブを実行中、Out of Memory のエラーが発生する場合には、この制限値を必要に応じて増加させてください。

ワークステーション - サーバー間の接続

Adviser ワークステーションは HTTP を経由して Adviser サーバーに接続する必要があります。

サーバーやデータベースをスキャンし Adviser サーバーにデータを書き込むほとんどのワークステーション側の処理は、Notes クライアントと NRPC を通じて行われます。

クライアント側のジョブが完了した際、サーバー側の処理を起動させるために、Adviser は HTTP 経由で REST サービスのエンドポイントを呼び出し、更新したデータを処理するサーバーアプリケーションを起動します。

デフォルトのワークステーション設置では、サーバーのアドレス帳に定義されている最初のホスト名でサーバーに接続しようと試みます。その接続はポート 80 番の SSL なしで行われます。

それぞれのサーバーに対して SSL 接続が必要な場合や、他のポート番号を使用して接続したい場合には、ワークステーションデータベースの「Workstation Configuration」文書にある HTTP Host Name フィールドを編集し変更できます。デフォルトでは、このフィールドはホスト名だけが入っています。プロトコルやポート名を次のように指定することもできます(例、https://teamstudio.com:499 ポート番号 499 上の SSL接続)。Adviserワークステーションとして振る舞う Notes クライアントを完全に終了させ、この設定を有効にするため再起動が必要です。この設定に関して、ヘルプが必要な場合は、チームスタジオのサポートへご連絡ください。

Notes に実装されている Java 6 JVM の制限により、大きなキーサイズの SSL は正常に動作しない可能性があります。

Anchor
Upgrading
Upgrading
Adviser のアップグレード方法

Adviser 6.0 以降のバーションからアップグレードするには次のステップに従ってください。  

  1. ターゲットサーバー上でコードを実行するのに必要な適切な ID で新しく入手したテンプレートに署名します(通常、管理者ID)
  2. この新しいテンプレートでサーバーにある Adviser のデータベースの設計を更新します。
  3. 「restart task http」コマンドを使って HTTP タスクを再起動します。(これは"quit http"してから続けて"load http"するのと同じです。"tell http restart" では、完全に JVM をリリースして新しいコードを発行することができませんので、使用しないでください)。
  4. ワークステーションとして振る舞う Notes クライントを完全に終了させて(WIndows のタスクマネージャーを使用して確認してください)、Notes を再起動してください。これで Adviser ワークステーションデータベースがサーバーのテンプレートに対する設計の変更を反映できます。
  5. 5分以内にワークステーションのエージェントが再始動します。  
  6. ブラウザUIで、新しいスキャンをスケジュールしてください。これで新しいバージョンに必要なデータを更新し、新しい機能を有効にします。ワークステーションが再始動するのを待って、スキャンを開始するのが安全です。このスキャンは、わーくステーションがアクティブになってから開始されます。
HTTP タスクを再始動した後、最新の Adviser の UI を見るため、ブラウザを閉じて、再起動する必要があるかもしれません。ほとんどの場合、ブラウザはアプリケーションのファイルをキャッシュしているため、Adviser の UI にエラーが表示されるかもしれません。これが発生した場合には、ブラウザの設定でブラウザがキャッシュしたローカルのコンテンツをすべて削除してください。例えば、Chrome では設定 > 詳細設定を表示 で閲覧履歴データの消去を行ってください。他のブラウザにも同様のオプションがあるはずです。

ブラウザとパスワード保存に関して

Adviser はブラウザ内の「パスワード保存」を使用した運用を現在サポートしていません。以前に保存したパスワードはブラウザの設定ページから削除してください。

日次スキャンのスケジュール方法

それぞれのサーバーの log.nsf にあるアクティビティデータは、デフォルトでは 10 日分のデータを保持し、Adviser はそのデータを収集することから、データを最新の状態にしギャップを無くすためにスキャンは定期的に実行することが重要です。

夜間のスキャンを有効にするには、Adviser サーバーアプリケーションを Domino Designer で開き、Schedule Nightly Scan エージェントを有効にします。実行サーバーを指定するプロンプトが表示された場合には、このサーバーアプリケーションが存在するサーバーを指定してください。また、そのサーバーでスケジュールエージェントを動作させることができる ID で署名されているかを確認してください。

デフォルトでは、このエージェントは毎日 1:00 AM に実行します。必要であれば、この実行開始時間を変更してください。

この Schedule Nightly Scan エージェントは、このアプリケーションの Scan Now ボタンを使ったマニュアルのスキャンと同じプロセスを実行します。このスキャンでは、カタログ情報の更新、前回のスキャンから新しい利用状況の読み込み、関連する判定基準などの再計算を行います。ワークステーションの処理はスキャン要求を有効にする必要があります。 

 

Usage Auditor からの利用状況データをインポートするには

利用状況データを収集している期間中、設定 Save Supporting Data 設定が有効になっていれば、Teamstudio Usage Auditor からデータをインポートできます。 詳細は Importing from Usage Auditor を参照してください。