Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Published by Scroll Versions from space TEADOC and version 6.2

...

Sv translation
languageja

Teamstudio Adviser はふたつの Lotus Notes アプリケーションから構成されており、IBM Notes 環境に関するデータをスキャンおよび集約しレポートを生成します。これには、サーバーから生の利用状況アクティビティログデータを収集する実行モジュールも含まれています。

Adviser のユーザーインターフェースは、Web アプリケーションとして提供され、HTTP が有効になっている単一の Domino サーバー上で運用します。主なるアプリケーション、TSAdviser.nsf は、Web アプリケーションとして動作し、サーバー上に NSF を作成して配置し Web ブラウザを経由して設定します。

カタログ、利用状況、複雑さのすべてのデータ収集は、異なるワークステーションで実行されるようにデザインされています。ふたつめのアプリケーション、TSAdviserWS.nsf は IBM Notes のワークステーションに配置します。このアプリケーションはスキャンをスケジュールし実行する役割を持っています。指定したワークステーションからサーバーアプリケーションのアクションを実行することで自動的に配置されます。スキャンはリソースを著しく消費するプロセスですが、異なるワークステーションから実行して、サーバーパフォーマンスの Adviser のインパクトを抑制し、複数ドメインのアクセスを容易にする利点があります。

IBM Domino アプリケーションから構成されており、ひとつは Domino サーバー上に配置する IBM Domino アプリケーションで、もうひとつは IBM Notes クライアントがインストールされたワークステーション上で実行されるプログラムです。

Adviser サーバーのアプリケーションは、Adviser のブラウザ・ベースのユーザーインターフェースを提供し、Adviser モジュールに対するデータベースとユーザーの様々なレポートを生成し、Adviser によって収集したすべてのデータを格納します。

Adviser ワークステーションは、Adviser サーバーによって生成されたレポートの基礎になるデータを収集する役割を担っています。Adviser ワークステーションは IBM Notes のインストールされたワークステーション上に、インストーラー(サーバーのNSF内に格納されています)を起動することで配置されます。このインストールされたプログラムは、Adviser サーバーに接続するようにインストーラーによって構成され、必要に応じて Adviser のスキャンプロセスを起動し続けます。スキャンはリソースを著しく消費するプロセスですが、異なるワークステーションから実行して、サーバーパフォーマンスの Adviser からのインパクトを抑制し、複数ドメインのアクセスを容易にする利点があります。

システム要件 

Teamstudio Adviser の Web ユーザーインターフェースは、Domino サーバーのバージョン 8.5.3 以降で運用します。

  • Domino 8.5.3 では、少なくとも Fix Pack 3 と Upgrade Pack 1 (または XPages Extension Library) がインストールされていなければなりません。
  • 上記に必要なコンポーネントは Domino 9.0 以降に含まれているので、追加のコンポーネントは必要ありません。

Teamstudio Adviser のワークステーションは IBM がサポートする Microsoft Windows 上で Notes クライアントが構成されている IBM がサポートするすべての 32 ビット構成をサポートしています。上の Notes 8.5.3 以降の 32 ビットをサポートしています。

既存のインストールをアップグレードする方法

Adviser 6.0 以降の既存のインストールからアップグレードする場合には Upgrading セクションを参照してください。そうでない場合は、下の方法に従ってください。

利用状況データ収集の前提要件

Teamstudio Adviser は IBM Domino サーバーのアクティビティロギングタスクで収集されたデータを元に、集積とレポートを行います。Usage Auditor の使用には、対象となるサーバーすべてにアクティビティロギングを有効化する必要があります。
アクティビティロギングはドミノディレクトリーのサーバー設定文書で有効にできます。Usage Auditor サーバーのアクティビティ・ロギングのタスクで収集されたデータを元に、集積とレポートを行います。

対象となるサーバーすべてにアクティビティロギングを必ず有効化する必要があります。アクティビティ・ロギングはドミノディレクトリーのサーバー設定文書で有効にできます。Teamstudio Adviser は次のアクティビティ・ストリームを追跡します:

  • Domino.Notes.Database
  • Domino.Notes.Session
  • Domino.AGENT
  • Domino.HTTP


Domino 上のアクティビティロギングの設定におけるデフォルトは、アクティビティの情報がサーバー上の デフォルトでは、アクティビティはサーバー上の Log.nsf データベースに書き込まれ、最新の 2 週間分だけアクティビティ情報が保存されるようになっています。Usage Auditor はアクティビティの収集において不足がないように定期的に動作するようになっています。つまり、アクティビティを Usage Auditor を使って記録すれば、レポーティングを開始した直後から「すべてのアクティビティ」のサマリー情報を保持できるようになります。上記のようにすでにアクティビティロギングの設定がオンになっていれば、Usage Auditor を直ちに起動し、設定を行うだけで に記録され、ある一定期間 Log.nsf 内のアクティビティをレポート可能になります。にアクティビティを保持するようになっています。Teamstudio Adviser は毎晩利用状況データを収集し、常に新しいデータのみをインポートします。ある夜の収集が失敗したとしても、データの保持期間内であれば利用状況データが失われることはありません。

Teamstudio Adviser Server のインストールと設定

インストール

メインとなるサーバーコンポーネントをインストールするには、サーバーコンポーネントをインストールするには、TSAdviser.ntf に対してプログラムコードを実行し、スキャンするサーバー群にアクセスできる適切な  に対してプログラムコードを実行、スキャンするサーバー群にアクセスできる適切な ID で署名する必要があります。そして、配置するサーバーにこのテンプレートを基に NSF を作成します。

Teamstudio Adviser を設定するには、次にアドレスを使用して Web ブラウザを経由してアプリケーションに接続します。 http(s)://<server>/<path>/index.html <server> は Domino サーバーのホスト名か IP アドレス、<path> はこの NSF のファイルパスを指定します。確認のために、この NSF では Notes クライアントで開いた際にこの URL を表示します。

インストールが成功すると、アプリケーションのホーム画面が表示されます。

ACL

Teamstudio Adviser サーバーは「Anonymous」のACLエントリが必要で、「アクセスなし」で「パブリック文書[読者]」の権限が必要です。この設定は Adviser ワークステーションがクライアント側でのジョブが完了したとき、サーバー側でのジョブを起動するのに必要です。Anonymousのアクセスはジョブを作成したりデータにアクセスするために使用できません。Webブラウザアプリケーションをサポートする Adviser のサービスで必要な権限として、Anonymous をそれ以上の高い権限に設定しないでください。Anonymous に高い権限を与えることは、サーバーが権限を必要とするのを妨げてしまうことになります。

If the environment does not allow Anonymous access (for example, it is prohibited at the server level via the Directory's Server document), it is possible to configure Adviser to store and use an HTTP Username/Password combination for this access.  For more information, contact Teamstudio support at techsupport@teamstudio.com.

通常、Adviser に設定するその他の ACL 設定は、普通のノーツアプリケーションに適用するのと同じ方法でブラウザアプリケーションにも適用できます。

「-Default-」アクセスは匿名のアクセスとして、必要となるどのレベルのアクセスにもアサインできます。


設定
Teamstudio Adviser サーバーでの設定の最後のステップは、スキャン対象のサーバーを指定することです。Web アプリケーションの Settings (設定) ページで行えます。設定ページは Adviser ナビゲーションバーの右側にある歯車アイコンからアクセスできます。詳しくは Servers を参照してください。

ワークステーション上に Adviser データ収集アプリケーションをインストールする方法

Adviser のデータ収集アプリケーションは TSAdviserWS.ntf というテンプレートを基にした Notes のアプリケーションです。

このアプリケーションはクライアントワークステーションからスキャンを実行するようにデザインされています。アクティビティをスキャンしレポートすることは、複数のサーバーにアクセスし、コンピュータープロセスの一部として動作する非常にリソースを消費するアものになります。

ワークステーションは、クライアントワークステーションからスキャンを実行できる実行可能なアプリケーションです。アクティビティをスキャンしレポートすることは、複数のサーバーにアクセスし、コンピュータープロセスの一部として動作する非常にリソースを消費するアものになります。

こうしてスキャンした利用状況アクティビティデータは、順次サーバーアプリケーションへ書き込みされ、Web ブラウザインターフェースを経由して利用できます。

Adviser ワークステーションはローカルの定期エージェントが動作する環境が必要で、保留されたジョブに対するサーバーアプリケーションの監視や、データ収集を動作させるの必要となります。 

アプリケーションはスキャン対象となるそれぞれのサーバーの Log.nsf ファイルに少なくとも読者権限のアクセスをもつ ID でインストールまたは動作させなければなりません。複雑さデータ収集が必要であれば、それぞれのアプリケーションに対しても同様のアクセス権がなければなりません。サーバー群が複数ドメイン内に存在している場合には、すべてのサーバーに対して相互認証されている ID とワークステーションが必要となります。

またこの ID は Adviser サーバーアプリケーションに対して、編集者(削除権限付き)の ACL アクセスを設定しなければなりません。

Adviser ワークスーテーションノーツアプリケーションをインストールするにはワークスーテーションアプリケーションをインストールするには:

  1. Adviser ワークステーションが動作するワークステーション上で、データ収集に使用される ID で IBM Notes クライアントにログインします。
  2. Notes クライアント設定の「定期ローカルエージェントの有効化」にチェックしてください。(ファイル > 設定 > IBM Notes クライアントの基本設定)。Notes クライアントのセキュリティ設定で「他の IBM Notes ベースのプログラムでパスワードプロンプトを表示しない(セキュリティが低下)」にチェックしてください(ファイル > セキュリティ > ユーザーセキュリティ)。これは実行モジュールを動作させるのに必要となります。
  3. Notes クライアントで Adviser サーバーアプリケーションを開き、Enable  Workstation Processing のリンクをクリックします:
    Image Removed

実行モジュールのインストール

Adviser は logscan.exe というユーティリティプログラムを使用します。これを使用して、 Domino サーバー群からアクティビティの生データを収集します。

スキャンが実行されて、Notes プログラムディレクトリーにこのユーティリティ・プログラムがまだインストールされていない場合には、Adviser は自動でインストールします。自動インストールには現在のユーザーがインストールに必要な適切な OS 上の権限があることが必要です。

Notes プログラムディレクトリーにこの実行モジュールが自動で保存されない場合など管理者権限が必要な場合には、このデータベースの ヘルプ > このアプリケーションについて に添付されています。マニュアルで Notes 実行ディレクトリーに保存してください。

保存してから、Notes で Usage Auditor を起動するユーザーアカウントをこの実行モジュールが読み取り、実行できる Winodws OS 上の権限を与えてください。

Usage Auditor の以前のバージョンからアップグレードをする際に情報やサポートが必要な場合は、次のTeamstudio サポート http://support.teamstudio.com または次のメールアドレスまでお問い合わせください 
  1. サーバーアプリケーションを開き、「Adviser ワークステーション」とタイトルのあるセクションのワークステーションを有効にするリンクをクリックします。
    Image Added
  2. Adviser インストールプログラムが起動します。プロンプトに従って処理を進めます。セットアップの途中、ワークステーションに対する設定情報を指定する設定ページが表示されます。サーバーに正しく接続するため以下の情報を確認して指定してください。:
    Image Added

インストールが完了すると、ワークステーションが起動するようになっています。

これまで使用していた Adviser のインストールからのアップグレードに関する情報は Upgrading セクションを参照してください。

Usage Auditor の以前のバージョンからアップグレードする場合には、弊社の技術サポート https://jp.teamstudio.com/support またはメール techsupport_japan@teamstudio.com.

ワークステーションの JVM メモリーの設定

Adviser ワークステーションは Java でプログラムされたスキャンジョブを実行します。 Complexity スキャンの実行中にサイズの大きな設計ノートや大きいサイズのデータキャッシュ(例えば、 Usage Auditor の以前のデータをインポートするなど)を処理するのに充分なメモリーが必要です。

Notes をインストールしたときのデフォルトの JVM ヒープの制限は 64 MB になっており、これでは大きなサイズの設計要素(例えば、大きな添付のあるフォーム)を処理するのには十分ではない場合があります。

この制限はワークステーションの Notes.ini パラメーター JavaMaxHeapSize=<バイト数> を指定することで変更できます。

当社では すくなくとも 128 MB、ほとんどの場合は 256 MB への変更を推奨します。

256 MB にヒープの制限値を変更するには、次の行を追加あるいは変更してください:  JavaMaxHeapSize=268435456

ワークステーションのジョブを実行中、Out of Memory のエラーが発生する場合には、この制限値を必要に応じて増加させてください。 にてご連絡ください。

Adviser ワークステーションの起動

インストールが完了している状態であれば、Adviser ワークステーションをインストールの際に使用した同じリンクをクリックして起動させることができます。Notes クライアントで Adviser サーバー NSF を開き、設定ページにある Adviser ワークステーションというタイトルのセクションのリンクから起動してください。:

Image Added

ワークステーションは同様に、Workstation.exe という実行ファイルを起動することでT動作します。デフォルトでは <Program Files (x86)>\Teamstudio\Adviser Workstation\Workstation.exe になります。

起動すると、ワークステーションのウィンドウが開き、保留になっているスキャンの監視を開始します:

Image Added

ワークステーション - サーバー間の接続

Adviser ワークステーションは HTTP を経由して Adviser サーバーに接続する必要があります。

サーバーやデータベースをスキャンし Adviser サーバーにデータを書き込むほとんどのワークステーション側の処理は、Notes クライアントと NRPC を通じて行われます。

クライアント側のジョブが完了した際、サーバー側の処理を起動させるために、Adviser は HTTP 経由で REST サービスのエンドポイントを呼び出し、更新したデータを処理するサーバーアプリケーションを起動します。

デフォルトのワークステーション設置では、サーバーのアドレス帳に定義されている最初のホスト名でサーバーに接続しようと試みます。その接続はポート 80 番の SSL なしで行われます。

それぞれのサーバーに対して SSL 接続が必要な場合や、他のポート番号を使用して接続したい場合には、ワークステーションデータベースの「Workstation Configuration」文書にある HTTP Host Name フィールドを編集し変更できます。デフォルトでは、このフィールドはホスト名だけが入っています。プロトコルやポート名を次のように指定することもできます(例、https://teamstudio.com:499 ポート番号 499 上の SSL接続)。Adviserワークステーションとして振る舞う Notes クライアントを完全に終了させ、この設定を有効にするため再起動が必要です。この設定に関して、ヘルプが必要な場合は、チームスタジオのサポートへご連絡ください。

Notes に実装されている Java 6 JVM の制限により、大きなキーサイズの SSL は正常に動作しない可能性があります。

Anchor
Upgrading
Upgrading
Adviser のアップグレード方法

Adviser 6.0 以降のバーションからアップグレードするには次のステップに従ってください。  

Adviser サーバーのアップグレード

  1. ターゲットサーバー上でコードを実行するのに必要な適切な ID で新しく入手したテンプレートに署名します(通常、管理者ID)
  2. この新しいテンプレートでサーバーにある Adviser のデータベースの設計を更新します。
  3. 「restart task http」コマンドを使って HTTP タスクを再起動します。(これは"quit http"してから続けて"load http"するのと同じです。"tell http restart" では、完全に JVM をリリースして新しいコードを発行することができませんので、使用しないでください)。ワークステーションとして振る舞う Notes クライントを完全に終了させて(WIndows のタスクマネージャーを使用して確認してください)、Notes を再起動してください。これで

Adviser

ワークステーションデータベースがサーバーのテンプレートに対する設計の変更を反映できます。
  • 5分以内にワークステーションのエージェントが再始動します。  
  • ブラウザUIで、新しいスキャンをスケジュールしてください。これで新しいバージョンに必要なデータを更新し、新しい機能を有効にします。ワークステーションが再始動するのを待って、スキャンを開始するのが安全です。このスキャンは、わーくステーションがアクティブになってから開始されます。
  • HTTP タスクを再始動した後、最新の Adviser の UI を見るため、ブラウザを閉じて、再起動する必要があるかもしれません。ほとんどの場合、ブラウザはアプリケーションのファイルをキャッシュしているため、Adviser の UI にエラーが表示されるかもしれません。これが発生した場合には、ブラウザの設定でブラウザがキャッシュしたローカルのコンテンツをすべて削除してください。例えば、Chrome では設定 > 詳細設定を表示 で閲覧履歴データの消去を行ってください。他のブラウザにも同様のオプションがあるはずです。

    ワークステーションのアップグレード

    6.2 より前の Adviser ワークステーションのインストールは、Notes クライアント内のローカル定期エージェントとしてワークステーション・コンポーネントを起動していました。これは、Notes の "data" ディレクトリーに配置される TSAdviserWS.nsf というアプリケーションでした。アップグレードには次の手順に従ってください:

    1. ワークステーションとして動作していた Notes クライアントを完全に終了させてください(タスクマネージャーで完全に終了しているか確認してください)。
    2. クライアントのデータディレクトリーから TSAdviserWs.nsf を削除してください。
    3. Notes クライントを再起動し、Adviser サーバーアプリケーションを開きます。
    4. 前出の Adviser ワークステーションのインストールの説明に従って、ワークステーションをインストールします。
    5. ブラウザ UI 内で新しいスキャンをスケジュールしてください。これで、新しいバージョンに必要なデータがアップデートされ、新しい機能が有効になります。ワークステーションを再起動する間に、新しいスキャンをスケジュールのが安全です。ワークステーションがアクティブになればスキャンは自動的に開始されます。

    お客様が Adviser ワークステーションのベータバージョン、つまりコマンドライン・アプリケーションをご使用になっている場合には、そのアプリケーションを終了し、前出の説明にある新しいワークステーション・アプリケーションをインストールしてください (新しいバージョンをインストールするには提供されているバージョンにもよりますが、 Windows のコントロールパネスの「プログラムと機能」で Adviser ワークステーションでアンインストールを施される場合もあります)。

    ブラウザとパスワード保存に関して

    Adviser はブラウザ内の「パスワード保存」を使用した運用を現在サポートしていません。以前に保存したパスワードはブラウザの設定ページから削除してください。

    日次スキャンのスケジュール方法

    それぞれのサーバーの log.nsf にあるアクティビティデータは、デフォルトでは 7-10 日分のデータを保持し、Adviser はそのデータを収集することから、データを最新の状態にしギャップを無くすためにスキャンは定期的に実行することが重要です。

    夜間のスキャンを有効にするには、Adviser サーバーアプリケーションを Domino Designer で開き、Schedule Nightly Scan エージェントを有効にします。実行サーバーを指定するプロンプトが表示された場合には、このサーバーアプリケーションが存在するサーバーを指定してください。また、そのサーバーでスケジュールエージェントを動作させることができる ID で署名されているかを確認してください。

    デフォルトでは、このエージェントは毎日 1:00 AM に実行します。必要であれば、この実行開始時間を変更してください。

    この Schedule Nightly Scan エージェントは、このアプリケーションの Scan Now ボタンを使ったマニュアルのスキャンと同じプロセスを実行します。このスキャンでは、カタログ情報の更新、前回のスキャンから新しい利用状況の読み込み、関連する判定基準などの再計算を行います。ワークステーションの処理はスキャン要求を有効にする必要があります。 

     

    Usage Auditor からの利用状況データをインポートするには

    利用状況データを収集している期間中、設定 Save Supporting Data 設定が有効になっていれば、Teamstudio Usage Auditor からデータをインポートできます。 詳細は Importing from Usage Auditor を参照してください。